Home / Magento / Magento 2x / The openssl extension is required for SSL/TLS protection but is not available.

The openssl extension is required for SSL/TLS protection but is not available.

$ php bin/magento setup:static-content:deploy
The openssl extension is required for SSL/TLS protection but is not available. If you can not enable the openssl extension, you can disable this error, at your own risk, by setting the 'disable-tls' option to true.#0 E:\xampp\htdocs\magento225\vendor\composer\composer\sr
c\Composer\Factory.php(325): Composer\Factory::createRemoteFilesystem(Object(Composer\IO\BufferIO), Object(Composer\Config))
#1 E:\xampp\htdocs\magento225\vendor\composer\composer\src\Composer\Factory.php(569): Composer\Factory->createComposer(Object(Composer\IO\BufferIO), Array, false)
#2 E:\xampp\htdocs\magento225\vendor\magento\framework\Composer\ComposerFactory.php(47): Composer\Factory::create(Object(Composer\IO\BufferIO), 'E:\\xampp\\htdocs...')
#3 E:\xampp\htdocs\magento225\vendor\magento\framework\Composer\ComposerInformation.php(362): Magento\Framework\Composer\ComposerFactory->create()
#4 E:\xampp\htdocs\magento225\vendor\magento\framework\Composer\ComposerInformation.php(375): Magento\Framework\Composer\ComposerInformation->getComposer()
#5 E:\xampp\htdocs\magento225\vendor\magento\framework\Composer\ComposerInformation.php(242): Magento\Framework\Composer\ComposerInformation->getLocker()
#6 E:\xampp\htdocs\magento225\vendor\magento\framework\App\ProductMetadata.php(104): Magento\Framework\Composer\ComposerInformation->getSystemPackages()
#7 E:\xampp\htdocs\magento225\vendor\magento\framework\App\ProductMetadata.php(65): Magento\Framework\App\ProductMetadata->getSystemPackageVersion()
#8 E:\xampp\htdocs\magento225\vendor\magento\framework\Console\Cli.php(91): Magento\Framework\App\ProductMetadata->getVersion()
#9 E:\xampp\htdocs\magento225\bin\magento(22): Magento\Framework\Console\Cli->__construct('Magento CLI')

You need to open Xammp folder/php/php.ini and Cntr+F and find extension=php_openssl.dll and uncomment it, If you couldn’t find it then you need to find by openssl if you can’t find it too then please add this below code to php.ini any line.

extension=php_openssl.dll

Hits: 80